Update: Don’t use this method any more, please install hplip instead, and make sure to remove foo2zjs and hannah, because they conflict with hplip.

  1. Install CUPS # apt-get install cups # adduser youruser lpadmin # adduser youruser lp
  2. Follow instructions from http://foo2zjs.rkkda.com/ to install the driver
  3. Add your printer
    • a. http://localhost:631/ (Web-based CUPS GUI)
    • b. # apt-get install foomatic-gui $ foomatic-gui &
    • c. Add your printer with foomatic-gui like here

Blessings!